1

Locorider

Mitglied

  • »Locorider« ist der Autor dieses Themas

Wohnort: Nördl. Halbkugel - kältere Polarregion

  • Private Nachricht senden

1

Donnerstag, 9. November 2017, 11:14

Keine Aufgaben-Auswertung

Moin moin...

...nach Jahren der MSTS-Abstinenz habe ich diesen für mich wieder entdeckt. Also, flux installiert und gestartet. Alles funktioniert...na ja, fast alles...aber dazu später mehr.

Dann bin ich bei The Train erst einmal durch die Dateien getobt und habe das "DR 142 Set" von Gabberspatz entdeckt und mußte natürlich sofort eine kleine Aufgabe für dieses Set schreiben. Schnell das Add-On "Werratal" installiert und losgelegt. Alles prima, Aufgabe läuft, bis ich die Aufgabe beenden wollte.

Das Problem ist, wenn ich im Meldungs-Fenster "Aufgabe beenden" auf "OK" drücke, steigt der TS komplett aus (finde mich auf dem Desktop wieder) und ich erhalte keine Aufgaben-Auswertung. Ich habe inzwischen ALLE !! Kompatibilitäts-Modi (von Win 95 bis Win 7) auch mit den Parametern für die "train.exe" mit den Einstellungen:

  • kein
  • -mem:512
  • -mem:1024
  • -mem:2048

durchgetestet. (habe dafür 8 Wochen gebraucht) Aber das Ergebnis war immer das Gleiche...Keine Änderung !!...der TS steigt aus ohne Aufgaben-Auswertung !! :wall:

Um jetzt ganz sicher zu gehen, habe ich die "Geislinger Steige" (PT-3) installiert, eine kurze Aufgabe geschrieben und...keine Aufgaben-Auswertung...Problem besteht weiterhin. :wall: Also, noch ein Versuch: schnell den "Rennsteig" (PT-22) installiert, kurze Aufgabe geschrieben und...keine Aufgaben-Auswertung. :wall:

Ihr seht also, ich habe nicht gleich aufgegeben und mich sehr mit dem Problem beschäftigt. Auch das Durchtauschen der Rollmaterialien brachte keinen Erfolg. Auch habe ich die Aufgaben mit und ohne KI, sowie mit und ohne statische Zugverbände getestet. Keine Änderung !!

Weiterhin habe ich für jedes Add-On einen eigenen TS !! Der Installations-TS, sowie alle anderen TS befinden sich auf LW D !!...nicht auf C.

Ich benutze weder das "Train-Store-Prg" noch den "Bin-Patch" !! Dennoch habe ich den Bin-Patch dahingehend getestet (V. 1.8.052113) Keine Änderung !!

Auch habe ich den "4-GB-Patch" (obwohl bei einem 64-Bit-System nicht notwendig) getestet, mit und ohne "Bin-Patch"...Keine Änderung !!

Auch habe ich mit den Optionen (Sound, Anzeige und Grafik) ´rumgespielt von gering bis sehr hoch...Keine Änderung !!

Meine generelle TS-Einstellung für Sound, Anzeige und Grafik ist alles auf Maximum.



Also, ich bin mit meinem Latein am Ende !!

Wenn jemand eine Lösung hat, bitte, bitte helft mir !!



Hier noch mein System:

  • Win 7 Home Premium 64-Bit
  • Intel Quad-Core 3.0 Ghz QX 9650 Extreme
  • XFX 3-way i780 SLI Mainboard
  • 8 GB DDR-2 1200 Ram
  • Nvidia Geforce GTX 550 ti 1 GB DDR-5 Ram
  • HD-1: 240 GB-SSD
  • HD-2: 240 GB-SSD (Spiele-LW)
  • HD-3: 150 GB WD Raptor (Arbeits-LW)
  • HD-4: 320 GB Samsung (Arbeits-LW)
  • HD-5 ext. USB-3: 500 GB Toshiba (Sicherungs-LW)

Gruß ICH

Locorider
8) ...keep on raillin´...Locorider 8)

2

2

Donnerstag, 9. November 2017, 16:19

Hallo

Zitat

Gruß ICH
, dass du weder TrainStore noch den BinPatch nutzen möchtest ist natürlich deine Sache aber keinesfalls Empfehlenswert.
Mit deinem Fehler hat es aber sicher nichts zu tun. Wie sieht es denn mit den Aufgaben in deinem InstallationsTS aus, also da wohin auch der Pfad der Registry - oder die Aufgaben von TS Unpack hin installiert weden. Funktioniert dort das Beenden der Aufgaben ordnungsgemäß ? Wie sind die anderen Installationen entstanden ? Eventuell den Fehler durch kopieren verbreitet ?
Liebe Grüße, Jan

3

Joe

Mitglied

Wohnort: Heidelberg

  • Private Nachricht senden

3

Donnerstag, 9. November 2017, 16:19

Anwort zu: Keine Aufgaben-Auswertung

Hallo Locorider,

da hast du ja alles mögliche ausprobiert, bis auf den MSTS auf einen Kern zu binden.

Bei Multicore System lässt Windows einen Prozess von Kern zu Kern springen. Dies verträgt der alte MSTS nicht so gut.

Lies mal unter Der MSTS bleibt immer wieder "hängen" - ein Fall für die Kernzuweisung nach.

Gruß Joe

4

4

Samstag, 11. November 2017, 19:48

Hallo Locorider,

klappt es inzwischen? Mich würde zu Deiner Problembeschreibung noch interessieren, ob der MSTS auch bei Standardaufgaben abschmiert, die Du nicht selbst editiert hast? Bspw. eine Standardaufgabe des MSTS auf einer der Standardstrecken. Vielleicht ist das Problem viel simpler und hängt mit dem definierten Aufgabenziel zusammen. Immerhin funktioniert der Rest ja offenbar einwandfrei.

lG weinrich86

5

rk54

Berufshesse

Wohnort: Garmisch Bad Darmstadt

  • Private Nachricht senden

5

Sonntag, 12. November 2017, 08:46

@ Alle,
es besteht auch die Möglichkeit dass die Aufgabe nicht korrekt abgeschlossen wurde.

Gruß RK54
ich hab keine Ahnung, aber davon jede Menge

Darmstadt liegt zwischen 3 Meeren,
tagsüber, ein Häusermeer
nachts ein Lichtermeer,
nach 22 Uhr, nix meer

6

Locorider

Mitglied

  • »Locorider« ist der Autor dieses Themas

Wohnort: Nördl. Halbkugel - kältere Polarregion

  • Private Nachricht senden

6

Samstag, 18. November 2017, 17:04

Keine Aufgaben-Auswertung

Hai Leute..



...sorry, daß ich mich erst jetzt melde, aber es geht alles nicht so schnell, denn das Testen verschiedenster Aufgaben beansprucht doch ein wenig Zeit...und es gibt ja noch ein Leben neben dem TS...aber wem erzähle ich das... :D

Aber zunächst möchte ich auf eure Antworten beziehen...

@Kapitaen13

Das Prg "TrainStore" benutze ich nicht, weil ich damit nach geraumer Zeit schlechte Erfahrungen gemacht habe. Mit zunehmender Installation mehrerer AddOns (40 plus) hat sich TrainStore immer öfter verschluckt und der TS hat immer öfter gemeckert (konnte mehrere Dateien nicht finden). Bzgl. des "BinPatch": ich bin mir nicht sicher, wie die Aufgaben mit und ohne BinPatch funktionieren, bzw. verändert der BinPatch das Verhalten der Aufgaben (Zeitverschiebung der KI-Züge und Bahnhofs-Aufenthalten ??) Ich habe eine Zeitlang als Ghostwriter für ein anerkanntes AddOn-Unternehmen Aufgaben erstellt, und da wurde das Benutzen des BinPatch untersagt, aus oben genannten Gründen.



@Joe

ich danke Dir für den Link zum GR-Forum. War sehr interessant. Ich ahbe eerstmal mit "msconfig" kontrolliert und gesehen: die CPU lief nur mit dem ersten Kern (hatte nach dem Einbau einer neuen SSD Win 7 neu installiert und die Verstellung noch nicht vorgenommen). Dann habe ich die Parameter der TrainExe bzgl des Links angefügt. Aber es ergab sich keine Änderung meines Problemes.



@Weinrich86

Der TS schmierte auch bei Standard-Aufgaben ab. Die Aufgaben wurden zwar beendet, aber bei OK stürzte der TS kommentarlos ab (keine Aufgaben-Auswertung).



@rk54

...da gibt es zwei Möglichkeiten. Bei normalem Otrtsereignis "Aufgabe erfolgreich beendet" ist alles gut...nur bekomme ich keine Aufgaben-Auswertung (TS steigt aus). Ändere ich aber die Einstellung des Ortsereignisses und setze das Häkchen "Zug muß anhalten", kann die Aufgabe nicht beendet werden.



Nachdem ich letzten Dienstag mit einem Kumpel bei einem Kaffee an meiner Stamm-Tanke mit ihm über mein Problem sprach (er spielt auch seit Jahren TS) hat er mir gesagt, ich solle mal alle Kerne aktivieren und die Parameter aus dem GR-Forum wieder löschen, bis auf dem mem-Eintrag und dieser sollte ein viertel des eingebauten Speichers umfassen. Ihr könnt euch vorstellen, daß ich diesem Rat gefolgt bin, zumal mein Kumpel Informatiker ist. Und was soll ich euch sagen: Der TS läuft besser als vorher (kein Witz). Nach dieser Umstellung bzw. Aktivierung aller Kerne habe ich diverse Aufgaben gefahren und konnte ALLE ordnungsgemäß beenden...jjiippeee... :dance1: :dance1:

...bis ich dann meine erstellte Aufgabe getestet habe...und wieder keine Aufgaben-Auswertung... :wall: ...bei normalem Ortsereignis wird mir die Meldung "Aufgabe erfolgreich beendet" angezeigt, aber beim Klick auf "OK" steigt der TS ohne Kommentar aus... :wall: ...bei einem Ortsereignis "Zug muß anhalten" kann die Aufgabe nicht beendet werden und ohne Aufgaben-Ende keine Aufgaben-Auswertung... :wall:



Ich habe auch bei der Aufgabe mehrfach das Ende und auch die Versetzung des Umkehrpunktes durchgetestet...aber das Problem besteht weiterhin... :wall: ...wenn jemand die unbändige Lust verspürt sich meines Problemes anzunehmen, dem schicke ich gerne die Aufgabe...



Gruß ICH
8) ...keep on raillin´...Locorider 8)

7

7

Montag, 20. November 2017, 13:31

Hallo,

dann scheint es ja an Deiner Aufgabe zu liegen, wenn die anderen funktionieren. Beschreib doch mal, was da alles gemacht werden muss. Miteinander verknüpfte Zeitereignisse, Aktionsereignisse, Ortsereignisse usw. Vielleicht hast Du mehrere Auswege aus dem Szenario konzipiert und einer führt den MSTS irre.

lG weinrich86

8

Locorider

Mitglied

  • »Locorider« ist der Autor dieses Themas

Wohnort: Nördl. Halbkugel - kältere Polarregion

  • Private Nachricht senden

8

Montag, 20. November 2017, 17:59

Keine Aufgaben-Auswertung

Hallo weinrich86...

...also, der Spieler soll von Eisenach nach Breitungen fahren (GR-3 Werratal), ganz einfach. In Breitungen muß er dann den Zug zurückdrücken auf das Kraftwerkgleis 4...färtsch...alles gut...funktioniert alles...nur das Beenden der Aufgabe funktioniert nicht...auch das versetzen der Spieler-Route in Breitungen änderte das Problem nicht.

Gruß ICH
8) ...keep on raillin´...Locorider 8)

9

rk54

Berufshesse

Wohnort: Garmisch Bad Darmstadt

  • Private Nachricht senden

9

Montag, 20. November 2017, 18:12

@ Locorider,
und was ist wenn Du die Lok abhängst und ein Stück vor fährst, oder auf ein Abstellgleis ?

Gruß RK54
ich hab keine Ahnung, aber davon jede Menge

Darmstadt liegt zwischen 3 Meeren,
tagsüber, ein Häusermeer
nachts ein Lichtermeer,
nach 22 Uhr, nix meer

10

10

Montag, 20. November 2017, 23:46

Hallo,

neben der obigen Frage von rk54... Jetzt hast Du zwar beschrieben was passiert, aber nicht wie es definiert ist. Wird das Act auf dem Kraftwerkgleis durch ein Ortsereignis beendet? Es gibt vermutlich keinen Fahrplan oder Zwischenhalte, die erfasst werden? Andere Kontrollpunkte, ob der Spieler macht, was er soll? Gesetzte Zeitereignisse, bis wann das Fahrtziel erreicht sein muss?

lG weinrich86

11

Locorider

Mitglied

  • »Locorider« ist der Autor dieses Themas

Wohnort: Nördl. Halbkugel - kältere Polarregion

  • Private Nachricht senden

11

Dienstag, 21. November 2017, 10:00

Keine Aufgaben-Auswertung

Moin moin...

@rk

...habe ich auch schon gemacht, Lok abgehängt, ein kleines Stück vorgefahren, dann wieder angekuppelt und den Zug auf das Kraftwerkgleis 4 gedrückt...auch das hat nicht geholfen...denn dort ist das Ortsereigniss zum Beenden des Acts.

@weinrich86

...ja sicherlich wird das Act durch ein Ortsereigniss beendet: Zug muß anhalten - Aufgabe erfolgreich beendet...keine Wirkung !! Ich bin auch dreimal über den Ereignisspunkt gefahren, habe jedesmal angehalten...aber nix !! Nein einen Fahrplan gibt es nicht, Güterzug...keine Kontrollpunkte, keine Zeitereignisse, keine Zeitbeschränkung...eine ganz einfache Aufgabe um das "DR_142_Set" von Gabberspatz zu testen...mehr nicht...nix weltbewegendes.

Gruß ICH
8) ...keep on raillin´...Locorider 8)

12

rk54

Berufshesse

Wohnort: Garmisch Bad Darmstadt

  • Private Nachricht senden

12

Dienstag, 21. November 2017, 10:13

@ Locorider,
schau Dir mal Aufgaben von mir an, alles Güterzugacts, alle mit Fahrplan.
Warum soll ein GZ keinen Fahrplan haben?
Wie machst Du das dann mit Begegnungen oder Überholungen?
Einfach mal fahren und schauen was passiert ist keine gute Idee

Gruß RK54
ich hab keine Ahnung, aber davon jede Menge

Darmstadt liegt zwischen 3 Meeren,
tagsüber, ein Häusermeer
nachts ein Lichtermeer,
nach 22 Uhr, nix meer

13

13

Dienstag, 21. November 2017, 11:16

@Locorider
Wenn das Ortsereignis absolut alles ist, was diese Aufgabe ausmacht, könnte hier das Problem liegen. Die Aufgabe ist dadurch unendlich lang, weil alles nur davon abhängt, ob der Spieler am Punkt X vorbeikommt. Zudem ist dem MSTS nicht klar, was der Spieler in dieser unendlichen Zeit macht. Da ist also ein großes Nichts, was die MSTS-Engine womöglich fertig macht.

Einen Fahrplan könnte man zumindest so verwenden, dass es ein Zeitlimit gibt, um am Kraftwerksgleis anzukommen. Und/oder aber man setzt mal das Aktionsereignis "Wagen abstellen" als definiertes Ziel ein. Könnte mir vorstellen, zur Zeit hast Du gar keine Zieldefinition und beendest die Aufgabe nur mit dem Ortsereignis.

Ansonsten wars das nun von mir. Hoffe, es klappt.

lG weinrich86